Author Topic: What am I doing wrong with my MIDI's  (Read 1063 times)

0 Members and 1 Guest are viewing this topic.

Offline Denn

What am I doing wrong with my MIDI's
« on: May 08, 2023, 01:27:08 AM »
What  am I doing wrong with my MIDI's? I set up everything that I need to play my song like this:
Ambient Piano R1, Vibes R2 Style "Easy Listening" set this to button 1 on my reg bank
Now change the transpose to +3 (Eb) and set that to button 2
Now change the transpose to +7 (G) and set that to button 3.
Record the midi and when I play it back it is all in the key of C!! No change in key.
So, much against my usual performance, I record the song in Audio (wav) and it works fine. I have the change of key.
If I play the midi back and at the correct time I press button 2 then the key changes, likewise with button 3. But I want the midi to record what I play and not what it wants to do.
Question is; What am I doing wrong?
Help Please.
Regards, Denn.
Love knitting dolls
 

Offline Fred Smith

Re: What am I doing wrong with my MIDI's
« Reply #1 on: May 08, 2023, 02:34:15 AM »
What  am I doing wrong with my MIDI's? I set up everything that I need to play my song like this:
Ambient Piano R1, Vibes R2 Style "Easy Listening" set this to button 1 on my reg bank
Now change the transpose to +3 (Eb) and set that to button 2
Now change the transpose to +7 (G) and set that to button 3.
Record the midi and when I play it back it is all in the key of C!! No change in key.
So, much against my usual performance, I record the song in Audio (wav) and it works fine. I have the change of key.
If I play the midi back and at the correct time I press button 2 then the key changes, likewise with button 3. But I want the midi to record what I play and not what it wants to do.
Question is; What am I doing wrong?
Help Please.
Regards, Denn.

I've run into this problem before.

There are 3 transpose assign settings: Song, Keyboard and Master

Song transposes only the Song; Keyboard transposes only the keyboard; Master transposes both.

From what I remember, I suspect you have Transpose Assign set to Master, when it needs to be Keyboard.

Cheers,
Fred
Fred Smith,
Saskatoon, SK
Sun Lakes, AZ
Genos, Bose L1 compacts, Finale 2015
Check out my Registration Lessons
 

Offline Denn

Re: What am I doing wrong with my MIDI's
« Reply #2 on: May 08, 2023, 04:47:31 AM »
Thanks Fred, Went through almost (note almost :D) everything I knew. When I got your answer I tried again. Mixing console, highlight the keyboard and set the transpose. This has to be REGISTERED to the particular button. It took a lot of variations until I got it. So, for button 1 set them all to zero, for button 2 set only the keyboard to +3 the others stay at 0 Same with button 3 set to +7 This gives my first play in C, the next bit in Eb and the next in G. Fabulous!
Thanks a million. Another thing under my belt. Still finding things after 10 years  :)
Kind Regards, Den.
Love knitting dolls
 

Offline EileenL

Re: What am I doing wrong with my MIDI's
« Reply #3 on: May 08, 2023, 12:56:42 PM »
Nearly all Yamaha keyboards have, and still do work this way. If recording Midi and you want the transpose to record you must have it set to keyboard.
Eileen
font]