Author Topic: Error linking to Yamaha registration bank  (Read 428 times)

0 Members and 1 Guest are viewing this topic.

Offline Kath001

Error linking to Yamaha registration bank
« on: April 29, 2021, 08:47:40 AM »
Hi, I am at my wits end, 2 days now trying to connect my Genos, iPad and songbookplus.  I have set the Genos to access point mode, I can see it in the WiFi links on my iPad, I select it, open songbook plus, open my song pdf and click the 3 dots and select the option to link to my registration but every time I get the message “error linking to Yamaha registration bank.  I have tried everything I can think of, I change ipadresses, channels, restarted the midi numerous times and still nothing.  I assume there is something wrong with the midi setting as the word midi next to the 3 dots has a solid white line the a smaller blinking line underneath.  Has anyone any suggestion as to what’s wrong. I and no technical person so simple instruction please as I am sure you are all way above me on the techie side.  Thanks
 

Offline Patrick

Re: Error linking to Yamaha registration bank
« Reply #1 on: April 29, 2021, 12:23:10 PM »
Hi Kath, try to disconnect your Ipad from songbook+, and reconnect it; try to link your song again, all the best Patrick
 :)
 

Offline Kath001

Re: Error linking to Yamaha registration bank
« Reply #2 on: April 29, 2021, 04:09:52 PM »
Thanks no luck I even deleted the app and reinstalled it but still same error.
 

Offline overover

Re: Error linking to Yamaha registration bank
« Reply #3 on: April 29, 2021, 05:38:08 PM »
Hi Kath001,

please make sure that in the Genos Wireless LAN settings (Access Point Mode) the option "DHCP Server" is ON. Make also sure that the WiFi connection between the iPad and Genos has been established properly (WPA2 by entering the correct password set on the Genos).

On the Genos set the Preset MIDI template "All Parts". This ensures that SysEx messages can be transmitted and received.

Start the Songbook+ app, touch the "gear" symbol and then "MIDI" to call up the MIDI settings. Here make sure that at "EASY KEYBOARD CONTROL" the option "Control mode YAMAHA Genos ... Registrations (with link)" is activated.

There are also other important MIDI settings on this page. It would be best if you could post a screenshot or a photo of your current MIDI settings in Songbook+ here.


Best regards,
Chris
« Last Edit: April 29, 2021, 05:40:57 PM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!
 

Offline Kath001

Re: Error linking to Yamaha registration bank
« Reply #4 on: April 29, 2021, 07:27:30 PM »
You’ve cracked it for me, it was the midi not set to ALL PARTS.  The Genos was set up linked to my Lowrey organ by the shop I bought it from so when I changed it fromLowrey to all parts it worked a treat, thank you so much.


 

Offline overover

Re: Error linking to Yamaha registration bank
« Reply #5 on: April 29, 2021, 08:13:39 PM »
You’ve cracked it for me, it was the midi not set to ALL PARTS.  The Genos was set up linked to my Lowrey organ by the shop I bought it from so when I changed it fromLowrey to all parts it worked a treat, thank you so much.

Hi Kath001,

I am glad that my tips helped you!


If you want to use your "Lowrey" MIDI template again, you can add the correct SysEx settings to it:

Load the "Lowrey" template, go to "System" tab > page 2/2 and set "System Exclusive Message" both "Transmit" and "Receive" to ON. Then touch "Save" to save your edited template in User drive. (To prevent the original "Lowrey" template from overwriting, it is best to enter a new or altered filename.)

Make sure that your newly saved MIDI template is activated now (!)


P.S.
There is an additional manual, especially for the configuration of Songbook+ in connection with Genos and PSR-SX models. If you don't already have this manual, you can download it here:
>>> http://www.baum-software.ch/downloads/OtherManuals/Manual_Yamaha_Genos_SongBook.pdf

You can look it up again in the section "3.1 Using WiFi to directly connect the keyboard" of this manual if necessary. All the important settings are there. However, they forgot to point out that SysEx Receive & Transmit must be activated on the Genos (which, as I mentioned, can be done e.g. by activating the "All Parts" template). ;)


Best regards,
Chris
« Last Edit: April 29, 2021, 08:56:44 PM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!
 

Offline Bonzai99

Re: Error linking to Yamaha registration bank
« Reply #6 on: May 04, 2021, 08:35:04 AM »
Hello all.  so i just purchased a new ipad pro and I am having the exact same issue as Kath001 stated here in the beginning.
I have my Ipad connect properly to my Genos because I am in the Access Point Mode, Midi is set to "All Parts" and my Midi light is blinking on the songbook + App.
Next, I choose the PDF file on songbook, Load the song on Genos and choose " Link the Song"
I get the same message as above  'Error linking to Yamaha registration bank'
am I missing something else.  ?
 

Offline overover

Re: Error linking to Yamaha registration bank
« Reply #7 on: May 04, 2021, 12:33:41 PM »
Hello all.  so i just purchased a new ipad pro and I am having the exact same issue as Kath001 stated here in the beginning.
I have my Ipad connect properly to my Genos because I am in the Access Point Mode, Midi is set to "All Parts" and my Midi light is blinking on the songbook + App.
Next, I choose the PDF file on songbook, Load the song on Genos and choose " Link the Song"
I get the same message as above  'Error linking to Yamaha registration bank'
am I missing something else.  ?

Hi Bonzai99,

first of all, on GENOS you have to load a REGISTRATION (not a "Song"). You can only link Genos Registrations (not MIDI Songs directly) to Songbook+ "Songs".

Please read the P.S. of my last post. If you have not already done so, download the additional Songbook+ manual for Genos and read the mentioned section 3.1 of this manual.

When working with a Wireless MIDI connection (Genos is set to Access Point Mode) it must be ensured that the following settings are made in the MIDI settings of Songbook+:

MIDI INPUT/OUTPUT
Channel: 1
Show MIDI button in toolbar: ON
MIDI-IN enabled: ON
MIDI-OUT enabled: ON

WIRELESS MIDI SERVER
Activate: OFF

WIRELESS MIDI CLIENT
Activate: ON
Host: Enter here the IP Address shown in the WLAN settings of the GENOS (by default 192.168.0.1)
Port: 5004

MIDI START/STOP
Normally both switches are OFF

EASY KEYBOARD CONTROL
Control mode YAMAHA Genos ... (with link)

GENERAL KEYBOARD CONTROL
Normally both switches are OFF


Hope this helps!

Best regards,
Chris
« Last Edit: May 04, 2021, 12:39:00 PM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!
 

Offline Bonzai99

Re: Error linking to Yamaha registration bank
« Reply #8 on: May 05, 2021, 03:21:34 AM »
Thanks Chris for your reply and suggestions.  I have all the settings in Genos and the songbook midi correct as you suggested.  My midi light is blinking and my easy keyboard control is set for Yamaha Genos registrations with link
I have a genos registration selected with button 1 set for "after the Lovin'  I open "after the Lovin " on songbook+ and select "link this Song"
next the error message appears.
  seems like my next move will be to try to link up with a bluetooth transmitter???

Ive run out of options.  Thanks again for your help Chris 
 

Offline overover

Re: Error linking to Yamaha registration bank
« Reply #9 on: May 05, 2021, 09:54:33 AM »
Hi Bonzai99,

you probably have just overlooked something, because with the correct settings it MUST work.

Please double-check that the MIDI template "All Parts" is selected on the Genos and that at "System Exclusive Message" both Transmit and Receive are set to ON.

And double-check in the SB+ MIDI settings that the "Wireless MIDI Client is ON and the IP Address is exactly entered/written as shown in the WLAN settings of the Genos. Very important is also, as already mentioned, that the Port is set to 5004 there.


Basically, a "MIDI-over-Bluetooth LE" connection is more stable and easier to configure than a "MIDI-over-WiFi" (Wireless LAN) connection. For live performances in front of an audience, I recommend using a Bluetooth LE MIDI adapter (or a USB cable connection). For use only at home, MIDI over WiFi is sufficient.


There are several suitable Bluetooth LE MIDI adapters, for example:

- Yamaha MD-BT01 (unfortunately bad Firmware update support; doesn't work with Windows 10)
(I don't recommend Yamaha UD-BT01, because an additional power supply is needed here.)

- CME WIDI Master (good Firmware update support)

- Quicco Sound mi.1 II (very small; does not have to be unplugged for transport)


Best regards,
Chris
« Last Edit: May 05, 2021, 10:01:03 AM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!
 

Offline Bonzai99

Re: Error linking to Yamaha registration bank
« Reply #10 on: May 07, 2021, 04:46:01 PM »
Thanks Again Chris  I have tried and tried and checked and checked all my settings and followed the Manual to the T.  Nothing seems to make this connection successfully.  I have even been emailing back and for with BauM-Software  .  He is the one that also suggests that I just go to Bluetooth.  So hopefully once that arrives I can finally get connected.  Ive been working on this for 3 days now.  I did finally get all my PDF files loaded into Songbook+
Thanks so much for hanging in there with me and all your advice
Danny