Author Topic: Display doesn't show Voice selected from DAW  (Read 590 times)

0 Members and 1 Guest are viewing this topic.

Offline tparker24

Display doesn't show Voice selected from DAW
« on: February 14, 2021, 09:21:29 PM »
I'm using my DAW (Cakewalk) to drive my PSR-SX600.

I can successfully send sysex messages to select a Style, and then the selected Style shows up nicely on the SX600 main display.  In the screenshot below, for example, I did a sysex from Cakewalk to select the "Foxtrot" style.

I can also successfully send Program Change messages to select a Voice, however the selected Voice does NOT show up on the SX600 display.  The Voice sounds properly, it just doesn't show up on the SX600 display like the Style does.

In the same screenshot below, I had Cakewalk select the Harmonica voice.  It plays fine, but the display still shows "ConcertGrand".

I wonder if I'm missing a setting?

 

Offline overover

Re: Display doesn't show Voice selected from DAW
« Reply #1 on: February 14, 2021, 11:42:59 PM »
Hi tparker24,

welcome to the PSR Tutorial forum!


The SX600 contains two independent MIDI Ports (Port 1 Receive & Transmit, Port 2 Receive & Transmit).

Normally the DAW addresses Receive Port 1 of the SX600 (as it is set correctly for you at the moment). If the Preset MIDI template "All Parts" is used, the internal SONG Parts of the SX600 (Receive Port 1, Ch 1 - 16) are addressed.

Only the Voices of the Keyboard Parts are shown in the Main display (Right 1, Right 2, Left). To see the current Voices of the SONG Parts, you have to open the Mixer Display and go to Song 1 - 8 or Song 9 - 16 tab. Then select the ICON of the desired Voice to open the Voice Selection Display. There you can see the Voice name.

By the way: You can display the Voice Number for each Voice in the Voice Selection Display (#MSB-LSB-PRG). To do this, call up "MENU > Menu2 > Utility > Config2 > 1 Voice Number" and select "Show".


P.S.
If for whatever reason you want to control the Keyboard Parts of the SX600 from the DAW, there are several options. If you are working with the DIN MIDI IN on the SX600, you would have to set one of the Keyboard Parts Right 1, Right 2 or Left for the desired channels at "Receive Port 1" (instead of "Song").

If you work with USB-MIDI, you can simply set USB-MIDI Port 2 on the DAW for the respective tracks. Please note that on "Receive Port 2" the Keyboard Parts are assigned by default to the following MIDI channels:

Ch 1: Keyboard (to connect to an external Master Keyboard)
Ch 2: Right 1
Ch 3: Right 2
Ch 4: ----
Ch 5: Left

If necessary, this assignment can of course be changed in the MIDI Display > Receive tab. (Finally, you need to save the changes as a User MIDI template on the User drive.)


Hope this helps!

Best regards,
Chris
« Last Edit: February 15, 2021, 12:11:47 AM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!
 
The following users thanked this post: tyros5psr

Offline tparker24

Re: Display doesn't show Voice selected from DAW
« Reply #2 on: February 15, 2021, 01:01:32 AM »
overover, thanks very much for the welcome, and for the detailed info on my issue.  There's a lot there, so it'll take me a bit to digest it all and then try out some of those options.   Thanks so much for your help, and getting me started!

Tom
 

Offline tparker24

Re: Display doesn't show Voice selected from DAW
« Reply #3 on: February 15, 2021, 02:04:50 AM »
To see the current Voices of the SONG Parts, you have to open the Mixer Display and go to Song 1 - 8 or Song 9 - 16 tab. Then select the ICON of the desired Voice to open the Voice Selection Display. There you can see the Voice name.

That did the trick!  :)

It's a bit circuitous, but it gets the job done.  Thanks again for your help.

Tom

PS: FYI, the SX600 has just USB-MIDI ... no DIN MIDI IN.
« Last Edit: February 15, 2021, 02:08:49 AM by tparker24 »