Author Topic: Settings changing in Registrations  (Read 1620 times)

0 Members and 1 Guest are viewing this topic.

Offline Duffy

Settings changing in Registrations
« on: November 03, 2020, 07:55:30 PM »
i have just answered a post on Synthzone where a guy says that his midi files sometimes change tempo although they are saved in a Registration (although on a PSR, not a Genos)
This has happened to me on a few occasions on my Genos and whilst thinking about it, I wondered if any one else has noticed this.
I also have other strange happenings - it's a fairly regularly occurrence that I load a Registration and an edited Slow String has been changed to a different string giving a different sound entirely.
The other weird happening with Registrations is that the Main piano (no. 1 in the Piano Folder) keeps getting changed for a piano from the Legacy Folder.
None of these changes happen to sax, flute, or any other voices so, why should my pianos and strings keep getting changed like this.
I prefer my board to stick to the settings which I carefully make rather than be intelligent and make changes of it's own. No point making & saving registrations if they can change.
 

Offline Fred Smith

Re: Settings changing in Registrations
« Reply #1 on: November 03, 2020, 08:06:59 PM »
I use registrations all the time, and they stay exactly as I have memorized them. So the good news is you can get registrations to stay put.

The problem must be how you are saving the regs. You should post a registration or two so we can take a look at it for you.

Cheers,
Fred
Fred Smith,
Saskatoon, SK
Sun Lakes, AZ
Genos, Bose L1 compacts, Finale 2015
Check out my Registration Lessons
 

Offline overover

Re: Settings changing in Registrations
« Reply #2 on: November 03, 2020, 09:22:09 PM »
Hi Duffy,

you probably have MIDI files in which so-called "Keyboard Voice Meta Events" have been saved. This always happens if, when you save the files again after editing them on the keyboard under "MIDI Multi Recording > Setup", the checkmark for "Keyboard Voice" is set.

Please do the following test: Load a Registration in which a MIDI file is linked and in which the "correct" keyboard Voices actually stored in the Reg are not loaded.

After calling up the relevant Reg for the first time, please press the same Reg button again. This time the "correct" settings for the Left and Right Voices should be loaded.

If you encounter exactly this error, you will need to remove the "Keyboard Voice Events" from this MIDI file. The easiest way to do this is with the PC (Windows) program "PSRUTI". (See also the attached picture.)
>>> http://heikoplate.de/psruti.html

If the problem persists, please contact us again here!


P.S.
If you have also linked a STYLE in your Registration, please make sure that "OTS LINK" is NOT activated.


Best regards,
Chris
« Last Edit: November 03, 2020, 09:28:34 PM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!
 

Offline Duffy

Re: Settings changing in Registrations
« Reply #3 on: November 04, 2020, 10:21:26 AM »
Hi Duffy,

you probably have MIDI files in which so-called "Keyboard Voice Meta Events" have been saved. This always happens if, when you save the files again after editing them on the keyboard under "MIDI Multi Recording > Setup", the checkmark for "Keyboard Voice" is set.

Please do the following test: Load a Registration in which a MIDI file is linked and in which the "correct" keyboard Voices actually stored in the Reg are not loaded.

After calling up the relevant Reg for the first time, please press the same Reg button again. This time the "correct" settings for the Left and Right Voices should be loaded.

If you encounter exactly this error, you will need to remove the "Keyboard Voice Events" from this MIDI file. The easiest way to do this is with the PC (Windows) program "PSRUTI". (See also the attached picture.)
>>> http://heikoplate.de/psruti.html

If the problem persists, please contact us again here!


P.S.
If you have also linked a STYLE in your Registration, please make sure that "OTS LINK" is NOT activated.


Best regards,
Chris

thanks Chris ,
I have PSRUTI on my computer so I will try that when it happens again.
I have probably 4 or 5 Registrations where this has happened but, until it happens again, I don't know which registrations they are.
Does that mean that there is a fault in the Genos operating system or is it the way I have saved a Midi or Reg.
 

Offline Duffy

Re: Settings changing in Registrations
« Reply #4 on: November 04, 2020, 10:36:18 AM »
I use registrations all the time, and they stay exactly as I have memorized them. So the good news is you can get registrations to stay put.

The problem must be how you are saving the regs. You should post a registration or two so we can take a look at it for you.

Cheers,
Fred
Thanks Fred,
I now know what to do about the Midi when it happens again but Still no wiser about voices changing in my Registrations.
It's not the same Reg every time so, until it happens again I don't know which reg to post.
I know that Genos will replace voices on old Registrations thinking it is being intelligent but I don't want it to change voices at all, especially to voices I don't like such as Kino Strings.
When it changes my piano voices, it always changes them to a piano in the Legacy Folder but the new voices such as CFX Concert Grand are supposed to be better than the Legacy voices and
there is not much point having them if the board won't let me save them in Registrations.
I will save the next funny Reg and try and get to the bottom of the problem.
It seems strange that no one else is having this problem but I only save Registrations in the normal way as I did on my Tyros 4.
 

Offline overover

Re: Settings changing in Registrations
« Reply #5 on: November 04, 2020, 11:32:50 AM »
thanks Chris ,
I have PSRUTI on my computer so I will try that when it happens again.
I have probably 4 or 5 Registrations where this has happened but, until it happens again, I don't know which registrations they are.
Does that mean that there is a fault in the Genos operating system or is it the way I have saved a Midi or Reg.

Hi Duffy,

thanks for the quick feedback!

It's NOT a fault in the Genos operating system. On all PSR-S/SX models, all Tyros models and Genos, you can either use Registrations (which is probably the best method in most cases), OR you can use OTS (One Touch Settings of the Styles), OR you can save your Keyboard Voice Settings directly to MIDI files (as mentioned above).

IF you use Registrations, your MIDI files should NOT contain any "Keyboard Voice Meta Events". To avoid saving the current Keyboard Voice settings into your MIDI files when you re-save an edited MIDI file, make sure that the checkbox "Keyboard Voice" is NOT ticked in "MIDI Multi Recording > Setup". Usually only the top 7 checkboxes (Voice ... EQ) should be ticked here. (See also the attached picture.)


P.S.
To find MIDI files that contain such Keyboard Voice events, you can simply load the files directly (i.e. without a  Registration). If the current Keyboard Voice settings change when loading a MIDI file, this file contains such Keyboard Voice events, and you can easily remove them with PSRUTI.

If you click on "Save" button in PSRUTI, the source file will be overwritten without confirmation. I generally recommend making a backup copy of the original file beforehand.


Best regards,
Chris
« Last Edit: November 04, 2020, 11:45:33 AM by overover »
Everyone always said: "This is not possible!" - Then someone came and ... just did it!