Author Topic: Genos Audio File Volume Problem  (Read 1797 times)

0 Members and 1 Guest are viewing this topic.

Offline murrayb

Genos Audio File Volume Problem
« on: October 31, 2019, 02:09:50 PM »
Hi Folks:

While analyzing the any changes to the registration file for Song A and Song B to support YRM, I discovered that there is a problem when saving Audio files.

If you memorize an audio file to a new button with just the Audio box selected, the volume section of the registration is not created, a thus there is no place in the reg to store volume.  With no place to store the value it becomes totally unavailable.

However, if you check both MIDI and Audio boxes (even without a MIDI file), the volume section of the registration is created and audio volume is stored normally.

The strange thing about this is MIDI no longer uses that section to store volume, with 1.41 they've reverted to the prior to Genos location that had been deleted.  I believe this was done because the original section also included the channel on/off settings and needed to be reinstated.

I hope Yamaha have recognized this problem and we see a fix in Genos 2.0

Cheers,

Murray

One can do without most things, but not without the pleasure of music.

Check out my Registration Manager at:  http://psrtutorial.com/util/best.html
 

Re: Genos Audio File Volume Problem
« Reply #1 on: October 31, 2019, 02:46:47 PM »
Hi Murray,

thank you for providing this information!

Did you report this bug to Yamaha, as a "precaution"?


P.S.
Are you planning to support also the PSR-SX models in a new version of YRM?


Best regards,
Chris