Author Topic: SX900 troubles?  (Read 55180 times)

0 Members and 2 Guests are viewing this topic.

Offline rgw

SX900 troubles?
« on: October 25, 2019, 04:45:54 PM »
I see two members have has to return their keyboards back for repair or replacement.
Doesn't bode well I think.

Richard.

Offline Danny1972

Re: SX900 troubles?
« Reply #1 on: October 25, 2019, 04:57:48 PM »
Wow really!? What were the problems?
 

Offline Toril S

Re: SX900 troubles?
« Reply #2 on: October 25, 2019, 05:36:06 PM »
My S970 broke down. So it can happen. There are hundreds of electrical components in there, so it has to happen sometimes. But all in all Yamaha has good and reliable products.
Toril S

Genos, Tyros 5, PSR S975, PSR 2100
and PSR-47.
Former keyboards: PSR-S970.

https://www.youtube.com/channel/UCLVwWdb36Yd3LMBjAnm6pTQ?view_as=subscriber



Toril's PSR Performer Page
 

Offline EileenL

Re: SX900 troubles?
« Reply #3 on: October 25, 2019, 11:25:30 PM »
Hi  Richard,
  I know of one Blackpool. Who is the other one. I have had mine now for five weeks and is working as it should do sweet as a nut.
 

Offline rikkisbears

Re: SX900 troubles?
« Reply #4 on: October 26, 2019, 02:13:18 AM »
Hi,
Blackpool is the only one Iím aware of also.
Best wishes
Rikki

SX 900
VArranger & Ketron Sd2
Band in a Box 2020
 

Offline Pino

Re: SX900 troubles?
« Reply #5 on: October 26, 2019, 02:55:34 AM »
No problems with mine, all good.

Maybe Richard will come back and tell us where he saw the second SX 900 needing repair.

Pino
SX900 - Ketron SD40 - Maui 5s
 

Offline rgw

Re: SX900 troubles?
« Reply #6 on: October 26, 2019, 01:00:52 PM »
The two that I have seen are Toril S and Blackpool on another topic.

Like Eileen I have to say so far I have not experienced any problems with the SX900. I have owned Yamaha Products now for 30 years and only once experienced a fault with a Keyboad/

Richard.
 

Offline EileenL

Re: SX900 troubles?
« Reply #7 on: October 26, 2019, 01:14:28 PM »
Hello Richard,
  I think you will find Toril had a 975 keyboard.

Offline Pino

Re: SX900 troubles?
« Reply #8 on: October 26, 2019, 01:20:24 PM »
Your Heading  "SX900 Troubles"

Fake News.
SX900 - Ketron SD40 - Maui 5s
 

Offline rgw

Re: SX900 troubles?
« Reply #9 on: October 26, 2019, 03:37:55 PM »
Not truly fake news Pino. Blackpool has had to return his. A little confusing that Toril mentions his 970 under the SX900 section IMHO.
 

Offline Pino

Re: SX900 troubles?
« Reply #10 on: October 26, 2019, 03:59:23 PM »
Not sure what happened to Blackpoolís SX,
Looks like YAMAHA has sold a few thousand of these already.
Havenít seen any problems reported on the other keyboard sites.
Iíve never had a Yamaha breakdown so fingers crossed.

Pino
SX900 - Ketron SD40 - Maui 5s
 

Offline EileenL

Re: SX900 troubles?
« Reply #11 on: October 26, 2019, 06:03:51 PM »
According to Blackpool his keyboard locked up but not sure what caused it. Usually this happens if you try to load something the keyboard can't read or is corrupt. We must just wait and see.

Offline rikkisbears

Re: SX900 troubles?
« Reply #12 on: October 26, 2019, 07:49:48 PM »
Hi,
Iíve always been in the habit of turning my keyboards off before plugging and unplugging usb sticks.  Not that I have to do it often.
Best wishes
Rikki

SX 900
VArranger & Ketron Sd2
Band in a Box 2020
 

Offline Toril S

Re: SX900 troubles?
« Reply #13 on: October 26, 2019, 09:22:59 PM »
I mentioned that my S970 broke down only to make the point that this can happen with all electronic devices. But it is very rare with Yamaha products. One person having trouble with his instrument must not lead us to think that the SX900 is faulty. It is a very good keyboard, that you can safely go out and buy😀
Toril S

Genos, Tyros 5, PSR S975, PSR 2100
and PSR-47.
Former keyboards: PSR-S970.

https://www.youtube.com/channel/UCLVwWdb36Yd3LMBjAnm6pTQ?view_as=subscriber



Toril's PSR Performer Page
 

Offline Danny1972

Re: SX900 troubles?
« Reply #14 on: October 26, 2019, 10:45:20 PM »
Hello All,

For the most part mine has been fine with the exception of one thing and that's sometimes when loading an expansion pack the load fails with an error message as follows: "failed to access data".

I thought it was because I was putting too many packs on at the same time but it's not that as after I tried a few times and it eventually loaded it.

It's happened on a couple of USB pen drives as well, they are brand new and listed as one of the compatible sticks to use as I made sure of that. So not sure what to make of this right now.
 

Offline EileenL

Re: SX900 troubles?
« Reply #15 on: October 27, 2019, 12:51:39 AM »
Do you always format the USB drives on the keyboard before using them. I have used Verbatim and Kingston USB's on all of my keyboards and never had a problem. Are you using packs that are for the keyboard you have as this can some times cause problems.

Offline Danny1972

Re: SX900 troubles?
« Reply #16 on: October 27, 2019, 01:29:53 PM »
Do you always format the USB drives on the keyboard before using them. I have used Verbatim and Kingston USB's on all of my keyboards and never had a problem. Are you using packs that are for the keyboard you have as this can some times cause problems.

Hi Eileen,

Thanks for the reply.

I'm using the Kingston USB's. I've bought both 16gb & 32gb sticks.

I formatted them on my laptop though and not from the keyboard so I may backup the content, format the sticks from the SX900 and copy it back to see if that helps.

However I did notice something. The packs that I had a problem with were on the 32gb drive, but when moving them to the 16gb drive they load first time without an issue. I wonder if there's an issue using 32gb drives? Perhaps the bigger the size the more pressure on access speed? I'm sure I read they were OK to use.

As for the packs themselves, they are the ones I use on my S975 which also include packs from the S970, all of them work fine.

Thank you again,
Danny
 

Offline EileenL

Re: SX900 troubles?
« Reply #17 on: October 27, 2019, 04:01:30 PM »
Hi Danny,
  I use a 32Gb verbatim Store n Go on my SX900 and I also used it on my 970. It is fast reading and ideal for recording WAV recordings to.
  But as Yamaha always say format it on your keyboard first.
« Last Edit: October 27, 2019, 04:02:36 PM by EileenL »
 

Offline stlpianoman

Re: SX900 troubles?
« Reply #18 on: October 27, 2019, 05:33:20 PM »
There are literally hundreds of thousand of these unit produced.
Through out the history of my ownership of Yamaha keyboards, I experienced only one breakdown.
I have owned the psr2000, psr3000, tyros 3, tyros 4, cvp209, and cvp409.
At the present time, I have 2 units tyros 5, psr-s975, cvp709 and the Genos.
One of my Tyros 5 units just stop working after 3 weeks on the job.
It was an emergency, without it I couldn't work.
I had a steady gig 4 nights a week at the Hideaway lounge in St. Louis.
I called customer service at Yamaha.
They wanted me to take it to a local service center here is St. Louis.
Needlessly to say, I was a little upset.
I was able to work up the ladder and actually got someone that was able to help.
They over night me a new replacement.
They send me a paid Fedex label to return the defective unit.
It was really strange, I used it on the job Friday and at the end of the night I turned it off, put it in the case and took it home.
Came back the next evening, set it up, turned it on and nothing happened.
It didn't even light up.
This is why I purchased the second unit so I wouldn't have to face that problem again.
All and all my experience through the years is that Yamaha equipment is  super reliable.
Mark.