Author Topic: Audio Phraser- sync issue  (Read 8737 times)

0 Members and 1 Guest are viewing this topic.

Offline logcoy

Audio Phraser- sync issue
« on: September 04, 2018, 06:37:08 PM »
Hi there,

Anyone is using Audio Phaser to create an Audio Styles?

I've got an issue. I've tried to create few Audio Styles and all of them have got the same problem.

For example if I play the style on  Main A only, without changing variations and without using Fill In's the Audio Loop is lagging. It isn't synchronized with all the other parts of the style. I have to mention that it is happen only when I play the style on higher tempo than default.

Well, it is ok but only for couple of tacts. If I play the style only on one variation for more than 20-30 tacts the Audio Loop is lagging.


I've used drum loops with 110 BPM to create an Audio Style (BTW: some of the loops I've made by myself so I'm sure that I cut them perfectly) 

I've loaded my loops to Audio Phraser. I set up exactly the same tempo in Audio Phraser, which is 110 BMP. The loops length is 8 bars. I have saved it as Audio Style- 110 BPM.

Later, using Style Creator I've added some other parts of the style (BASS, CHD1, CHD2, PAD, etc). When I play the style on default tempo which is 110, everything is fine. But if I play this style at higher tempo, for example 145 (which is allowed because when I change the tempo I can see what is max tempo) the Audio Loop is lagging after few bars (I mean more than 20 bars).

I know that probably no one is using only one Variation of the style for 20 bars or more but that's not the case. It shouldn't been like that. If my BPM limit of this style is 180BPM then I should be able to play it at  180BPM without any lagging.

So it looks like there is something wrong. Any of you have had the same issue?



There is also one more problem with Audio Styles. Fill In. While you play the style you have to press it just before next bar. If you press Fill In, in the middle of the tact it won't work.

It would be nice if Yamaha fix it. I really like Audio Phraser and the Audio Styles sounds really good... as long as they play properly.

Best Regards,
Mike


Offline pjd

Re: Audio Phraser- sync issue
« Reply #1 on: September 05, 2018, 02:18:08 PM »
Hi Mike --

Thanks for your post. Interesting. I gave up using Audio Phraser because of other recurring issues. Yamaha needs to test and debug this thing.

BTW, I don't usually moan and complain this much unless something really needs fixing... Yamaha?

I'm glad you're reporting what you've found. Thanks.

-- pj

Offline logcoy

Re: Audio Phraser- sync issue
« Reply #2 on: September 05, 2018, 06:18:06 PM »
I have already sent message to Yamaha. Hopefully they will contact their colleagues in Japan. I thinkt that all software is made in Japan.
I'm not sure if they gonna do anything in this case but if I see something wrong I always notify them :)
As far as I know Audio Styles technology is very complicated. Stetching wav file is very difficult without quality loss.
Will see if they do anything. I hope so :)

Best Regards,
Mike
 

Re: Audio Phraser- sync issue
« Reply #3 on: September 09, 2018, 03:06:47 AM »
I tested an Audio Style just after releasing Phraser Audio.
It works pretty well although there are very limited features.
You can see my demonstration test it here.

https://www.youtube.com/watch?v=SCms0xtxJVQ
 

Offline logcoy

Re: Audio Phraser- sync issue
« Reply #4 on: September 09, 2018, 10:15:10 PM »
Hi Snicker740,

Yeah, if you play only Audio Drum, it works pretty well. But try this style with the other parts of the style. Add BASS, CHD1, CHD2, PAD etc. Then change the tempo of the style. I can see that max tempo of your style is 222. So let's try 200. Start the style but don't change any Variation. Also don't press any Fill In's. Let it play for a while only on Main A (or Main B, C or D- does not matter which one). If you let it play on one Variation for about 30 bars then you can probably hear that the Audio Drum is not really synchronized with the other parts of the style.

I think that if you play your style on tempo 200 for about 20 or 30 seconds then you can hear it. Just make sure that you don't change any Variation and you don't press Fill In. And listen it with the other parts of the style. I'm pretty sure that after 20 or 30 seconds you can hear it.

I've asked some of my friends who made an Audio Styles using Audio Phraser and they have got the same problem.


If I play it on the default tempo, the same as default Audio Loop tempo then it is ok. But if I use much higher tempo I can hear lagging. Not straight away but after a while.


However I'm really glad that Yamaha has released Audio Phraser and we can make our own Audio Styles :)



Here is my Audio Style:

https://www.youtube.com/watch?v=sq8LACCQjyk

The Audio Loop comes form Ketron Audya (which in my opinion has the best drums). The default tempo of the loop was 110. On the video you can hear that I play it much faster. And nothing wrong with it. You can not hear lagging but only because I change the Variations quite often. And I use Fill In's as well.

But you can belive me or not, if I play it on Main A (example) for about 30 seconds without changing anything (no other Mains or Fill In's) then it won't be synchronized with the other parts of the style.


Anyway, I'm quite happy with this style. Especially Audya drums :)

Regards,
Mike
 
The following users thanked this post: Snicker740

Re: Audio Phraser- sync issue
« Reply #5 on: February 03, 2019, 03:02:39 AM »
Hi Snicker740,

Yeah, if you play only Audio Drum, it works pretty well. But try this style with the other parts of the style. Add BASS, CHD1, CHD2, PAD etc. Then change the tempo of the style. I can see that max tempo of your style is 222. So let's try 200. Start the style but don't change any Variation. Also don't press any Fill In's. Let it play for a while only on Main A (or Main B, C or D- does not matter which one). If you let it play on one Variation for about 30 bars then you can probably hear that the Audio Drum is not really synchronized with the other parts of the style.

I think that if you play your style on tempo 200 for about 20 or 30 seconds then you can hear it. Just make sure that you don't change any Variation and you don't press Fill In. And listen it with the other parts of the style. I'm pretty sure that after 20 or 30 seconds you can hear it.

I've asked some of my friends who made an Audio Styles using Audio Phraser and they have got the same problem.


If I play it on the default tempo, the same as default Audio Loop tempo then it is ok. But if I use much higher tempo I can hear lagging. Not straight away but after a while.


However I'm really glad that Yamaha has released Audio Phraser and we can make our own Audio Styles :)



Here is my Audio Style:

https://www.youtube.com/watch?v=sq8LACCQjyk

The Audio Loop comes form Ketron Audya (which in my opinion has the best drums). The default tempo of the loop was 110. On the video you can hear that I play it much faster. And nothing wrong with it. You can not hear lagging but only because I change the Variations quite often. And I use Fill In's as well.

But you can belive me or not, if I play it on Main A (example) for about 30 seconds without changing anything (no other Mains or Fill In's) then it won't be synchronized with the other parts of the style.


Anyway, I'm quite happy with this style. Especially Audya drums :)

Regards,
Mike


I think this problem is not so important, because if you play music normally, then with 8 bars you have pressed fill in once.
Perhaps you never play with 16 bars without hitting the fill each time.
 

Offline logcoy

Re: Audio Phraser- sync issue
« Reply #6 on: February 03, 2019, 09:38:04 PM »
I think this problem is not so important, because if you play music normally, then with 8 bars you have pressed fill in once.
Perhaps you never play with 16 bars without hitting the fill each time.

Well, I think it is quite important and I can explain you why. Yeah, usually we press Fill In's within 4 or 8 bars. I'm doing the same but there is another issue. You have to press Fill In when the bar is starting. You can't be late. If you press Fill in within half bar it will not play. It is the same with changing Variations. If you are on Main D and then you want to change it to Main A but you will not press the Main A button in correct time (I mean at the beginning of the Bar), the Variation will change but the Fill In will not play and in this case the audio loop is not reseting its counter but keep playing. It will be obviously playing Variation you choosed but because Audio Loop on Main D was delayed little bit after 8 bars it will keep playing with that delay. Only if you press it on time it will be without delay. Sometimes I have no time to press Fill In button or Variation button at the beginning of the Bar and if every single Variation has got 8 bars it will be enough that I don't change them or press the Fill In on time 3 or 4 times (3 x 8 bars = 24 bars) and after 24 Bars of continuous playing I can hear the delay. So this is not right. It shouldn't be like that.
 

Offline keranshi

Re: Audio Phraser- sync issue
« Reply #7 on: July 19, 2019, 02:40:41 PM »
We want to fix the program.
 

Online overover

Re: Audio Phraser- sync issue
« Reply #8 on: July 20, 2019, 12:10:37 AM »
We want to fix the program.

Hi keranshi,

did you realize that there is a new, improved version of "Audio Phraser" (V1.0.1 from 2019-06-28)?:

https://usa.yamaha.com/support/updates/yap_win.html


Version History:

[1.0.1]
・Improved tempo analysis accuracy.
・Solved some other minor problems.


[1.0.0]
・Initial release


Best regards,
Chris
Everyone always said: This is not possible! - Then someone came and ... just did it!
 

Offline logcoy

Re: Audio Phraser- sync issue
« Reply #9 on: October 25, 2019, 07:54:40 PM »
did you realize that there is a new, improved version of "Audio Phraser" (V1.0.1 from 2019-06-28)?

Hi, yes I did realize it. However I didn't have time to check it earlier.
Anyway I've already installed it and checked how it works now and I have to say that they have fixed the issue with the tempo accuracy. Yamaha- big thank you for that :)

Fill Ins still not fixed. We have to be very precise when we press the Fill In button. But that's not really big issue for me. I'm glad that the tempo accuracy have been fixed :)

Kind Regards,
Mike