Author Topic: PSR s900 problem  (Read 1402 times)

0 Members and 1 Guest are viewing this topic.

Offline hayseed

PSR s900 problem
« on: April 12, 2018, 11:44:09 AM »
Posting for a friend who is experiencing problems with her S900.
 She has similar problems as this video shows.   Anyone have any fixes, in the comment section of this video one poster suggests removing the screen and using the video out port.     

https://www.youtube.com/watch?v=j0rF_zdsPxI&sns=em

Thanks
Hayseed
 

Offline DonM

Re: PSR s900 problem
« Reply #1 on: April 12, 2018, 02:14:45 PM »
Screen failure was a known problem with the 900.  Yamaha replaced or repaired them at no cost for a long time, even after the warranty expired.  I doubt if they do after all this time though.  It wouldn't hurt to ask.
DonM
 
The following users thanked this post: hayseed

Online Afton72

Re: PSR s900 problem
« Reply #2 on: April 13, 2018, 01:10:54 PM »
Hi,
          :o ;) ;D                Just carelessly lost my first draft, so here goes again.

                 Seeing as the old 900 files are gone,  Wonder if one of Fred Smith's T4 video's fill the void.
In this case, I am thinking of the vid showing how to connect an iPad  (think it was), to the video-out of the T4.

  Some people have connected PC monitors & small TVs.

My screen light went bust,  it looked like a small fluro tube and I replaced it with diodes, I could have done a bit better job, as screen now only just bright enough, even with adjustment.
  So I'd now go for an external screen of some type. just a bit tricky setting up the first time.

   Good Luck,
                             Alan
 
The following users thanked this post: hayseed

Re: PSR s900 problem
« Reply #3 on: May 19, 2018, 04:07:03 AM »
My screen gave out last month creating popping and hissing from the LCD backlight failing.

I dispensed of the CCL (cold cathode lamp), its inverter board and replaced it with a very thin strip of high brighness LEDS at 12v and found a 12v internal source I could tap into.

Works perfect again.
 

Offline DonM

Re: PSR s900 problem
« Reply #4 on: May 19, 2018, 05:28:57 AM »
Great!  If one has the knowledge to do this, it would be an invaluable procedure to know because a LOT of 950s had screens go out.
Maybe it could be posted on the main site somewhere.
DonM
 

Offline travlin-easy

Re: PSR s900 problem
« Reply #5 on: May 19, 2018, 01:14:49 PM »
No reports of an S-950 display failure, probably because it's a totally different display than the 900 and 910.

Gary 8)
Love Those Yammies...