PSR Tutorial Forum

Genos (10 Boards) => Genos and iPad & Songbook+ => Topic started by: voodoo on February 17, 2018, 10:00:06 PM

Title: Songbook+ only works with midi port A
Post by: voodoo on February 17, 2018, 10:00:06 PM
I found out, that switching registrations with Songbook+ works, only if iPad is connected to Genos over midi port A. It works fine over WiFi, Bluetooth adapter BT-MD01 at port A, and with USB Camera connection kit over port A. It does not work with Bluetooth or usb on port B. This is because some midi sysex messages needed for this are sent only over port A.

Uli
Title: Re: Songbook+ only works with midi port A
Post by: StuartR on February 18, 2018, 12:46:31 AM
I found out, that switching registrations with Songbook+ works, only if iPad is connected to Genos over midi port A. It works fine over WiFi, Bluetooth adapter BT-MD01 at port A, and with USB Camera connection kit over port A. It does not work with Bluetooth or usb on port B. This is because some midi sysex messages needed for this are sent only over port A.

Uli

Needs to be checked in next week's update!
Title: Re: Songbook+ only works with midi port A
Post by: Fred Smith on February 18, 2018, 01:42:03 AM
I found out, that switching registrations with Songbook+ works, only if iPad is connected to Genos over midi port A. It works fine over WiFi, Bluetooth adapter BT-MD01 at port A, and with USB Camera connection kit over port A. It does not work with Bluetooth or usb on port B. This is because some midi sysex messages needed for this are sent only over port A.

This is incorrect. I am using the adaptor on Midi Port B, and have no trouble communicating with SongBook.

You probably need to check your midi setup for Port B.

Fred
Title: Re: Songbook+ only works with midi port A
Post by: zionip on February 18, 2018, 02:44:06 AM
I am also using the MD-BT01 on Genos MIDI port B with Songbook+.

Thanks,
Paul
Title: Re: Songbook+ only works with midi port A
Post by: voodoo on February 18, 2018, 05:56:39 AM
Fred and Paul,

thank you for your feedback. I hope you are right and itís me doing something wrong.

And you are sure that everything works when connected to port B? I try to describe my situation:

* I have connected several registrations with songs using the new Genos method.
* selecting songs in Songbook+ works fine, then Genos switches to the right registration.
* but when I change to a different registration bank and select a registration on a Genos, Songbook+ does not recognise the correct song. Only the registration number is transmitted, but not the registration bank.

Do both directions of communication work well in your setup?

Uli