Author Topic: Tyros 4 and Cubase midi connection problem please help  (Read 2055 times)

0 Members and 1 Guest are viewing this topic.

Offline mrgoldmaninc

Tyros 4 and Cubase midi connection problem please help
« on: May 21, 2016, 08:25:51 PM »
please I need help I have tyros 4 and I am trying to connect the cubase on Mac Yosemite with Tyros 4 here what I did so far I connect my host to tyros and Usb to Mac.  In cubase under device I did the device set up as instructed. Now what works is what I play cubase is recognizing but I cannot here it some body told me I will require Midi interface is it true? Or I can do this without please help.thnx
 

Offline Bill Grosse

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #1 on: May 22, 2016, 08:04:17 AM »
No - yoou do not need a MIDI interface because the USB to Host is a MIDI interface.

BUT - you do need to install the "Yamaha Steinberg USB Driver".

AND - you do have to set up the MIDI "IN" and "OUT" in each Track and also in the "Project Synchronization Setup" section found on the Transport Menu Drop Down List.

At the bottom of the PSS select your keybord for the MIDI TimeCode Out and also in the MIDI Clock Out sections.
I recommend a check mark in the "Always Send Start Message" box as well.

Try this and come back here if you are still having problems with this.

Bill G
I wasn't going to do anything today - so far, I'm on schedule, :)
 

Offline overover

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #2 on: May 22, 2016, 09:36:49 AM »
No - yoou do not need a MIDI interface because the USB to Host is a MIDI interface.

BUT - you do need to install the "Yamaha Steinberg USB Driver". ...

Hi mrgoldmaninc,

since T4 provides  only USB MIDI functionality (no USB Audio), I recommend NOT to use "Yamaha Steinberg USB Driver" (which provides MIDI & Audio).

The driver you should use is the "Yamaha USB-MIDI Driver". You can download it from the T4 download page (in your case the right version is "V1.3.2 for Mac"):

http://download.yamaha.com/search/product/?site=de.yamaha.com&language=de&category_id1=16277&category_id2=16084&category_id3=&product_id=1072947


Important: This driver provides ONE Transmit port ("Digital Workstation 1") that correspondends with the T4-internal MIDI settings of "MIDI A/USB" and TWO Receive ports ("Digital Workstation 1 & 2").

I recommend to use one of these two MIDI setups on T4: "All Parts" OR "KBD & Style". In Cubase, please set "Digital Workstation 1" for MIDI Input AND Output ports.

The port "Digital Workstation 2" is only needed if you want to send MIDI data (from Cubase) to T4's keyboard parts (R1-3 and Left) or to the style parts.

Receive port "Digital Workstation 1", however, is routed to T4's SONG parts (by default).


Regards,

Chris


« Last Edit: May 22, 2016, 12:46:25 PM by overover »
 

Offline Bill Grosse

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #3 on: May 22, 2016, 11:19:46 AM »
Thank you Chris - I did say the wrong USB driver.  :-[

Bill G
I wasn't going to do anything today - so far, I'm on schedule, :)
 

Offline mrgoldmaninc

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #4 on: May 22, 2016, 09:35:19 PM »
Thanks everyone helping me in this, I did try everthing that was suggested to me nothing is working but i notice something i think it has nothing to do with cubase instead it is my keyboard let me explain why! 

I used my standard midi cables instead of Host to Usb
i connected in into out and out into in of the keyboard
then i started my cubase and thereafter my tyros
i did nothing in the keyboard
in cubase i went to Device and then into device setup
i saw that midi in was Active and midi out was inactive
then i went to Device Manager here i assigned output as usb midi out
then i upload my song into cubase and played it worked like a charm
next i wanted to create some back ground strings so i created the track
assinged my ins and out as soon as i strike my key in tyros
midi went crazy the string was coming twice like harmony and second strike made string into piano.
so here what i think is going on my key board local is either on which i do not know how to turn it off or
my trasmit and recevie need to be setup according with cubase.  Please help Thanks

 

Offline Joe H

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #5 on: May 22, 2016, 11:54:14 PM »
mrgoldmaninc,

If you are using the MIDI Ports and not USB/MIDI then you will have to install the correct driver for your particular MIDI cable you are using with your (32 bit or 64 bit) machine.

With that setup in Cubase you will not see the Workstation as the MIDI Device, you will see your cable as the MIDI device.  (in my case this shows up as PSR S970 Yamaha UX-16).  And as Chris states, Cubase will send its MIDI transmission to the T4 MIDI A - Song Parts.

Joe H
Music is the Universal Language!

My Article: Using Multi Pads for EDM. Download Regs, Styles & MPs:  http://psrtutorial.com/music/articles/dancemusic.html
 

Offline overover

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #6 on: May 23, 2016, 01:28:23 AM »
Hi mrgoldmaninc,

when using a external USB MIDI interface, please connect the DIN connector named "MIDI OUT" (of the interface)  to the MIDI IN A jack on Tyros, and the DIN connector named "MIDI IN" (of the interface) connect to the MIDI OUT A jack on Tyros.

The MIDI OUT/IN B jacks on Tyros are NOT used!

Please check also the MIDI Setup: On Tyros please press "FUNCTION ---> MIDI" and be sure, that either "All Parts" or "KBD & Style" is activated.


If you have problems with a "MIDI loop" (when you press a key on tyros keyboard then you hear a "doubled" sound), you can do the following to "break" the loop:

On Tyros press "FUNCTION ---> MIDI ---> EDIT". Go to SYSTEM tab and switch the parameter "LOCAL CONTROL" to OFF. You can save these settings as a User MIDI setup by pressing "EXIT", tab to USER drive, pressing "SAVE", name your Setup an pressing "OK".

But keep in mind that you will hear NO SOUND when using this setting, if the Tyros is NOT connected to Cubase by MIDI!

For more details see Tyros4 Reference Manual, starting from page 124:

http://download.yamaha.com/search/result/?site=usa.yamaha.com&language=en&search=tyros4


The second method (which I would use) to "break" the MIDI loop is: Leave the MIDI Setup on Tyros at its "original" settings but in CUBASE turn OFF the "MIDI THRU" function (in order NOT to route the incoming MIDI signal back to the Tyros).


Regards,

Chris
« Last Edit: May 23, 2016, 01:47:28 AM by overover »
 

Offline mrgoldmaninc

Re: Tyros 4 and Cubase midi connection problem please help
« Reply #7 on: May 23, 2016, 07:15:34 PM »
Thanks everyone once again let me try all the suggestions and get back by this friday.Thanks